PULP Community
Occamy Verilator simulation error - Printable Version

+- PULP Community (https://pulp-platform.org/community)
+-- Forum: PULP's Community forum (https://pulp-platform.org/community/forumdisplay.php?fid=1)
+--- Forum: PULP General questions (https://pulp-platform.org/community/forumdisplay.php?fid=2)
+--- Thread: Occamy Verilator simulation error (/showthread.php?tid=321)

Occamy Verilator simulation error - pquanganh3105 - 06-14-2023

Dear sir,

I follow this instruction about Occamy: https://github.com/pulp-platform/snitch/tree/master/hw/system/occamy

However, when I ran command: make bin/occamy_top.vlt, I met this error:

%Error-PKGNODECL: occamy/snitch/hw/vendor/openhwgroup_cva6/core/include/ariane_rvfi_pkg.sv:20:17: Package/class 'riscv' not found, and needs to be predeclared (IEEE 1800-2017 26.3)

I recognize that your work-vlt/files lacks included file (it doesn't have snitch/hw/vendor/openhwgroup_cva6/core/include/riscv_pkg.sv so the simulator can not find package 'riscv') but whenever I ran the command above, work-vlt/files is automatically generated and it still remain lacking information.

How can fix that?

Many thanks

RE: Occamy Verilator simulation error - nils - 06-14-2023


thanks for pointing this out. We were able to reproduce the issue and fixed it in https://github.com/pulp-platform/snitch/pull/494. The fix has been merged into the master branch, so feel free to pull and try again.


RE: Occamy Verilator simulation error - pquanganh3105 - 06-15-2023

Hi Nils,

I have pulled new revision. However, I found this error when ran command make bin/occamy_top.vlt

verilator_bin: ../V3Ast.cpp:1144: void AstNode::v3errorEndFatal(std::ostringstream&) const: Assertion `0' failed.
%Error: Verilator aborted. Suggest trying --debug --gdbbt
%Error: Command Failed occamy/install-snitch/verilator-4.100/bin/verilator_bin --Mdir work-vlt/ -f work-vlt/files -Wno-BLKANDNBLK -Wno-LITENDIAN -Wno-CASEINCOMPLETE -Wno-CMPCONST -Wno-WIDTH -Wno-WIDTHCONCAT -Wno-UNSIGNED -Wno-UNOPTFLAT -Wno-fatal --unroll-count 1024 -Wno-SYMRSVDWORD -Wno-BLKLOOPINIT --trace --prof-cfuncs -j 4 --cc --build --top-module testharness

I have installed the correct version of Verilator 4.100 followed this link: https://pulp-platform.github.io/snitch/ug/setup-iis/

How can I fix that? 

Many thanks