Error while updating IPs
#3
(08-19-2020, 02:21 PM)bluewww Wrote: Looks like a python version issue to me. Good that you could fix it.

Well I didn't really fix it, that's the problem...

There are basically three things that don't work as expected when setting up a fresh PULPissimo, at least for me.

Obviously I follow all the steps from the GitHub but the three things are:

1) When I get to the step where I have to install the Software Development Kit, I have to install the system dependencies.
There I have to execute a script: 
Code:
./scripts/build-runtime

Unfortunately I get the following error:
Quote:bash: ./scripts/build-runtime: No such file or directory

Not sure what causes this error as there aren't that many steps before this one that could cause any problems.

Edit: I fixed this problem but a new one came up.
When getting the submodules via: 

Quote:
Code:
git submodule update --init

I get an error that I do not have permission.
There is already an issue related to this problem here but the proposed solution did not work for me.
I still wanted to link to it because maybe it will work for others that have the same problem.



2) When running 
Code:
./update-ips

on a fresh PULPissimo installation for the first time it updates the IPs without any error.
But when I try to do it again I always get the same error:
Quote:Updating ip 'apb_fll_if'...
Traceback (most recent call last):
  File "./update-ips", line 47, in <module>
    ipdb.update_ips()
  File "ipstools/ipstools/IPDatabase.py", line 525, in update_ips
ValueError: invalid literal for int() with base 10: b'
My Python versions:
Quote:python3 --version
Python 3.6.8

python2 --version
Python 2.7.5


It is really weird to me that the first time I run ./update-ips I won't get this error but only from the second time onwards.



3) When trying to run or build the pulp-rt-examples I get the following error:
Quote:Makefile:6: /local/lpla/pulpissimo/pulp-sdk//install/rules/pulp_rt.mk: No such file or directory

make: *** No rule to make target `/local/lpla/pulpissimo/pulp-sdk//install/rules/pulp_rt.mk'.  Stop.


I remember running it yesterday without a problem (first time, similar to the ./update-ips problem).
When trying to set the path to one of the pulp_rt.mk files (there is one in pulp-sdk/tools/pulp-rules/rules and one in pulp-sdk/pkg/sdk/dev/install/rules) I get the following error:
Quote:/local/lpla/pulpissimo/pulp-sdk/tools/pulp-rules/rules/pulp_rt.mk:15: *** PULP_CURRENT_CONFIG must contain the current configuration.  Stop.

Edit: This seems to be fixed now. I am still not sure what caused this behaviour. I ran the example 3 times and no problems so far.


I will once more try a fresh installation of PULPissimo, following all the steps from the GitHub.
At this point I don't even know where to start looking for a solution if even following all the steps will result in errors.
Maybe there is something obvious that I can't see right now so any help is greatly appreciated.
Reply


Messages In This Thread
Error while updating IPs - by LPLA - 08-19-2020, 12:34 PM
RE: Error while updating IPs - by bluewww - 08-19-2020, 02:21 PM
RE: Error while updating IPs - by LPLA - 08-20-2020, 11:43 AM
RE: Error while updating IPs - by LanXu - 12-11-2020, 01:59 AM

Forum Jump: