PULP-sdk on centOS: error during build + fix
Hello, and thanks for let me join inside your community!

I am writing this thread for sharing to all of you the problem I faced building PULP-sdk on a centOS 7 distribution; and how I solved that without let other people to struggle as I did for solving this.

I was trying to recreate and setup the PULPissimo platform due to functionality analysis. I Have installed each of the requested components (gcc, pulp-sdk, pulp-builder, PULPissimo) inside a generic root project folder called  <user_project_folder_path>. Each of those component has been built inside a dedicated folder. In order to be able to simulate the platform, one of the needed steps is to setup and build the sdk. I moved to the PULP sdk main page, and then followed these steps:
Then, I Set the requested env variables, linking the toolchain and vsim paths:

- export PULP_RISCV_GCC_TOOLCHAIN=<user_project_folder_path>/opt/riscv/bin
- export VSIM_PATH=<user_project_folder_path>/pulpissimo/sim

As suggested form the guide, I first need to download and build the PULPissimo sdk. Since I am running the project on a centOS 7 operating system, then I installed the suggested dependencies:

- sudo yum install git python36-pip python36-devel gawk texinfo gmp-devel mpfr-devel libmpc-devel swig libjpeg-turbo-devel redhat-lsb-core doxygen python-sphinx sox GraphicsMagick-devel ImageMagick-devel SDL2-devel perl-Switch libftdi-devel cmake cmake3 scons
- sudo python3 -m pip install --upgrade pip
- sudo python2 -m pip install --upgrade pip
- sudo python3 -m pip install artifactory twisted prettytable sqlalchemy pyelftools openpyxl xlsxwriter pyyaml numpy configparser pyvcd
- sudo python2 -m pip install configparser

and after I cloned PULP-sdk repo on branch master 

- cd <user_project_folder_path>
- git clone https://github.com/pulp-platform/pulp-sdk.git -b master
- cd pulp-sdk
- source configs/pulpissimo.sh
- source configs/platform-rtl.sh
- make all

The make command started the building for a while, but after at a time it gives the following error (showed also inside the attached screenshot):

camera/camera.cpp:24:22:: fatal error: Magick++.h: No such file or directiry
  #include <Magick++.h>
compilation terminated.

After double checking all the dependencies I started browsing and comparing the same steps using a fresh 16.04 Ubuntu distribution, with resulting that the whole process worked fine on Ubuntu but not on centOS distribution. After struggling and after a long research, I found that inside the dependencies was missing the development library furnished by Magick++. The related dependence was solved installing:

- sudo yum install GraphicsMagick-c++-devel

After calling again the build command make all, I’ve been able to complete the whole sdk build and setup process, which let me able to move throught the following steps in the process. I still don’t know if this error come for some kind of lacks inside my system or not. If someone inside the PULP team want to try and replicate the behaviour, would be nice to fix the missing dependence from the git list in order to solve this problem for all the users which are using the same operating system as me. Anyway, I Hope this might be useful for all those people will found the same error: here’s the fix which can help you saving a lot of precious time Smile
Thanks a lot, this is much appreciated.
Visit pulp-platform.org and follow us on twitter @pulp_platform

Forum Jump:

Users browsing this thread: 1 Guest(s)