Error during building RTL
#1
Hello,

I get this error while I am trying to build the RTL.

Code:
~/workspace/pulp$ make scripts
curl --proto '=https' --tlsv1.2 -sSf https://pulp-platform.github.io/bender/init \
    | bash -s -- 0.25.2
bender-init: Warning: No release for platform 'x86_64-linux-gnu-ubuntu22.04' version '0.25.2' found, using latest.
bender-init: Failed to download 'https://github.com/pulp-platform/bender/releases/download/v0.26.1/bender-0.26.1-x86_64-linux-gnu-ubuntu22.04.tar.gz'!
make: *** [Makefile:247: bender] Error 1

Can you please let me know what I am doing wrong ?


Solution:

I must change the bash version in the Makefile.
Code:
bender: ifeq (,$(wildcard ./bender))    
curl --proto '=https' --tlsv1.2 -sSf https://pulp-platform.github.io/bender/init \        
| bash -s -- 0.26.1    
touch bender endif
Reply
#2
(11-18-2022, 10:49 AM)bgeorge Wrote: Hello,

I get this error while I am trying to build the RTL.

Code:
~/workspace/pulp$ make scripts
curl --proto '=https' --tlsv1.2 -sSf https://pulp-platform.github.io/bender/init \
    | bash -s -- 0.25.2
bender-init: Warning: No release for platform 'x86_64-linux-gnu-ubuntu22.04' version '0.25.2' found, using latest.
bender-init: Failed to download 'https://github.com/pulp-platform/bender/releases/download/v0.26.1/bender-0.26.1-x86_64-linux-gnu-ubuntu22.04.tar.gz'!
make: *** [Makefile:247: bender] Error 1

Can you please let me know what I am doing wrong ?
Hi @bgeorge,

The issue is, that we did not yet package a binary for Ununtu 22.04 so far. However, the binaries for Ubuntu 18.04 should work just fine for you. Please head over to https://github.com/pulp-platform/bender/releases and download the binary for Ubuntu 18.04. Then place it in the top level directory of the cloned pulpissimo repo (make sure to rename the binary to "bender"). Afterwards it should work. 
Best,
Manuel
Reply
#3
Can you try to access:
https://github.com/pulp-platform/bender/....04.tar.gz

The error suggests you were not able to download this bender distribution. I can download this directly (i.e. from firefox or using wget).. Can it be that you do not have write privileges, or not enough space on your disk?

The script (https://pulp-platform.github.io/bender/init) is trying to be too cute, something may not have worked as it is running on your machine. Where are you running this (Ubuntu22 ??).. Not sure how much thgis was tested on Ubuntu22..

You should already have the 'init' downloaded.. can you on the command line try to run
init 0.25.2
Visit pulp-platform.org and follow us on twitter @pulp_platform
Reply
#4
Hi folks,

I found the error, and I have updated the initial post with the solution.

Thanks for your fast reply.
Reply


Forum Jump: