Help to run Hello Example
#5
Hi Again,

I have one more question, what is a "hart" reported by openOCD when i connect with FPGA target?

I had removed all stuffs related with riscv from /opt/, i did everything again (with compiler make as "pulp") step by step carefully, but still get the same issue..

I'm using Ubuntu 16.04 LTS 64bits
My bashrc is like this;


Quote:export PULP_RISCV_GCC_TOOLCHAIN=/opt/riscv/

export VSIM_PATH=/home/caninos/Documents/pulpissimo/repo/pulpissimo/sim

PATH=$PATH:/opt/riscv/bin

source /home/caninos/Documents/pulpissimo/repo/pulp-sdk/init.sh
source /home/caninos/Documents/pulpissimo/repo/pulp-sdk/sourceme.sh


I have no errors during all process...

I will post the final results, maybe it give some clue


Quote:adapter speed: 1000 kHz
Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.
   TapName             Enabled  IdCode     Expected   IrLen IrCap IrMask
-- ------------------- -------- ---------- ---------- ----- ----- ------
 0 riscv.unknown0         Y     0x00000000 0x10102001     5 0x01  0x03
 1 riscv.cpu              Y     0x00000000 0x249511c3     5 0x01  0x03
Info : clock speed 1000 kHz
Info : JTAG tap: riscv.unknown0 tap/device found: 0x10102001 (mfg: 0x000 (<invalid>), part: 0x0102, ver: 0x1)
Info : JTAG tap: riscv.cpu tap/device found: 0x249511c3 (mfg: 0x0e1 (Wintec Industries), part: 0x4951, ver: 0x2)
Info : datacount=2 progbufsize=8
Info : Examined RISC-V core; found 1024 harts
Info :  hart 0: currently disabled
Info :  hart 1: currently disabled
...

when i use GDB, as expected i get something like that, what shows the same thing that the compiler ;

Quote:(gdb) load
Loading section .data_tiny_fc, size 0x31c lma 0x1c000004
Loading section .init_array, size 0x2c lma 0x1c000320
Loading section .fini_array, size 0xc lma 0x1c00034c
Loading section .rodata, size 0x168 lma 0x1c000358
Loading section .data, size 0x10c lma 0x1c000cc0
Loading section .vectors, size 0xa0 lma 0x1c008000
Loading section .text, size 0x1f80 lma 0x1c0080a0
Loading section .l2_data, size 0x6c lma 0x1c010000
Start address 0x1c008080, load size 9812
Transfer rate: 7 KB/sec, 1226 bytes/write.
(gdb) disas
Dump of assembler code for function _start:
=> 0x1c008080 <+0>:    j    0x1c0080a0 <_stext>
   0x1c008084 <+4>:    j    0x1c0080ec <__rt_illegal_instr>
   0x1c008088 <+8>:    unimp
   0x1c00808a <+10>:    unimp
   0x1c00808c <+12>:    unimp
   0x1c00808e <+14>:    unimp
End of assembler dump.

when i run in gdb "continue" it never ends... some kind of loop or error i'dont know

any help is very welcome

best regards, Igor Ruschi
Reply


Messages In This Thread
Help to run Hello Example - by igor.lima - 12-01-2020, 08:05 PM
RE: Help to run Hello Example - by LPLA - 12-02-2020, 10:46 AM
RE: Help to run Hello Example - by meggiman - 12-02-2020, 06:19 PM
RE: Help to run Hello Example - by igor.lima - 01-11-2021, 08:00 PM
RE: Help to run Hello Example - by igor.lima - 01-12-2021, 07:00 PM

Forum Jump: